Config miners di Linux

Published on November 10, 2017, by in Tutorial.

Pada Linux Ubuntu / turunan Debian

Instalasi CLI

# wget https://minergate.com/download/deb-cli && sudo dpkg -i deb-cli && sudo apt-get install screen && screen
# minergate-cli -user email@email.com -xmr

CPU Miner Multi

# sudo apt-get update && sudo apt-get install libcurl4-openssl-dev libncurses5-dev pkg-config automake yasm && sudo apt-get install git && git clone https://github.com/wolf9466/cpuminer-multi && cd cpuminer-multi && ./autogen.sh && CFLAGS=”-march=native” ./configure && make && sudo apt-get install screen && screen
# ./minerd -a cryptonight -o stratum+tcp://xmr.pool.minergate.com:45560 -u email@email.com -p x

 

Pada linux Centos /AMI

Instalasi

# sudo yum install git automake gcc make curl-devel && git clone https://github.com/wolf9466/cpuminer-multi && cd cpuminer-multi && ./autogen.sh && ./configure CFLAGS=”-O3″ && make && screen
# ./minerd -a cryptonight -o stratum+tcp://xmr.pool.minergate.com:45560 -u email@email.com -p x

 

Selamat berkreasi.

Perbandingan menggunakan MinerGate di VPS dan PC Desktop

Published on November 8, 2017, by in Berita.

Kali ini akan membandingkan haserate yang dihasilkan dari mining menggunakan vps dan pc desktop yang sama-sama dipasang 3 core cpu.

Pada vps yang dipasang 3 core cpu hanya mendapatkan 32 H/s saja

Sedangkan pada pc desktop dipasang 3 core cpu mendapatkan 127 kH/s

sangat jauh hasilnya ternyata, jadi disarankan untuk mining menggunakan CPU MinerGate gunakanlah PC Desktop, karena hasil hasrate nya lebih besar.

Install MinerGate di Ubuntu 16.10 x64 bit

Published on November 8, 2017, by in Tutorial.

Mining Bitcoin melalui ubuntu akan lebih aman, karena ubuntu merupakan operating system opensource yang minim terhadap ancaman para tangan jahil.

Kali ini kita akan menggunakan MinerGate untuk menambang bitcoin dan coin lainnya di os ubuntu. Ikuti langkah berikut :

Buka terminal ubuntu dengan menggunakan user root, kemudian eksekusi perintah berikut satu per satu :

# sudo apt-get update
# sudo apt-get install libcurl4-openssl-dev git
# sudo apt-get install build-essential autotools-dev autoconf libcurl3 libcurl4-gnutls-dev
# git clone https://github.com/wolf9466/cpuminer-multi
# cd cpuminer-multi/
# ./autogen.sh
# CFLAGS=”-march=native” ./configure
# make
# sudo make install
# screen
# ./minerd -a cryptonight -o stratum+tcp://xmr.pool.minergate.com:45560 -u email@minergate.com -p x -t 1

ganti email@minergate.com dengan email akun anda yang anda daftarkan di minergate.

Sekarang cek pada dashboard minergate, cek mining kita sudah jalan atau belum. Selamat mencoba.

 

Hari Pertama Mining Bitcoin menggunakan GPU Asus EAH5450

Published on November 8, 2017, by in Berita, Tutorial.

Setelah merasa tidak puas mining menggunakan CPU yang menggunakan 3 core cpu dengan hasrate hanya 32 H/s sangat melelahkan, karena per hari paling cuman dapat 0.000005026 BTC .. resource boros penghasilan tidak seimbang.

Akhirnya mikir dan mencoba menggunakan GPU. Kali ini alat tempurnya pake PC Desktop Intel Core i-3, RAM 4 GB DDR3, GPU Asus EAH5450 1Gb. Dengan menggunakan Windows 7 x64 Profesional.

Aplikasi mining yang digunakan NiceHash Miner yang bisa didownload di https://miner.nicehash.com kalau saya pilih yang AMD karena GPU menggunakan AMD.

Sebelumnya kita registrasi NiceHash terlebih dahulu ke https://www.nicehash.com/register untuk mendapatkan wallet NiceHash.

Silakan install aplikasi NiceHash Miner tersebut yang telah kita download. Pada proses installasi akan melakukan download sekitar 147 Mb jadi siapkan koneksi internet yang bagus.

Setelah selesai maka akan terbaca GPU yang kita gunakan.

Langkah awal kita isi BitCoin Address yang telah kita daftarkan di NiceHash tadi dan WorkerName saya isi nama GPU yang digunakan saja.

Klik setting terlebih dahulu untuk melakukan bencmark pilih dengan nilai H/s tertinggi kemudian klik bencmark. Proses bencmark ini membutuhkan waktu yang lumayan lama, jadi bersabarlah.

Setelah selesai bencmark otomatis akan proses mining dan muncul command prompt seperti ini

 

Lumayan kecepatan menggunakan GPU ini 23.651 MH/s sangat jauh dibanding menggunakan CPU 3 core yang hanya dapet 32 H/s. dengan global rate 0.00111 mBTC/Day.

Sekian percobaan Mining dengan GPU.

 

 

 

Cara enable ssh root access di ubuntu 16.10

Published on November 5, 2017, by in Tutorial.

Masuk ke terminal menggunakan user root :

sudo nano /etc/ssh/sshd_config

Kemudian cari  :

PermitRootLogin prohibit-password

dan ubah menjadi :

PermitRootLogin yes

Restart SSH Service :

sudo service ssh restart

Silakan login menggunakan putty :

Anda berhasil login. Demikian semoga bermanfaat.

 

Tidak Bisa Install Let’s Encrypt SSL

Published on November 3, 2017, by in Tutorial.

Untuk domain yang sudah terinstall AutoSSL sebelumnya dan biasanya menggunakan SSL Comodo yang lama resolved nya, kita gunakan Let’s Encrypt SSL yang lebih cepet. Hanya saja kendalanya kita tidak bisa langsung install Let’s Encrypt SSL melalui plugin Let’s Encrypt tersebut, kita harus remove dulu ssl sebelumnya dengan cara :

remove dulu di cpanel pada menu Security -> SSL/TLS -> Install and Manage for Your Site ->Manage Installed SSL Website 
Lalu pilih Uninstall

 

setelah selesai kembali ke menu plugin LetsEncrypt, silakan lakukan proses seperti yang diinginkan

 

Demikian informasi singkat ini, semoga bermanfaat.

Tidak bisa Addon Domain di cPanel domain menggunakan nameserver lain

Published on November 3, 2017, by in Tutorial.

Fitur default cPanel adalah kita tidak bisa menambahkan domain ketika domain tersebut menggunakan nameserver lain, alhasil domain harus diarahkan ke server kita terlebih dahulu. Ini terkadang merepotkan bagi yang ingin melakukan migrasi hosting.

dengan pesan error seperti berikut :

(XID zua4d4) Sorry, the domain is already pointed to an IP address that does not appear to use DNS servers associated with this server. Please transfer the domain to this servers nameservers or have your administrator add one of its nameservers to /etc/ips.remotedns and make the proper A entries on that remote nameserver.

Untuk memperbaiki masalah tersebut, kita masuk ke WHM ikuti langkah berikut :

  1. Login ke WHM menguunakan user root
  2. Masuk ke Tweak Setting
  3. Cari menu Domain
  4. Cari Allow Remote Domains
  5. Klik ON dan Save

Seperti pada tampilan berikut :

 

Demikian, semoga bermanfaat.

Downgrade dan Install versi LiteSpeed

Published on October 4, 2017, by in Tutorial.

Misal mau downgrade dari 5.1.17 ke 5.1.13, gunakan perintah ;

/usr/local/lsws/admin/misc/lsup.sh -f -v 5.1.13

Intinya perintah tersebut digunakan install LiteSpeed dengan versi tertentu yang kita  tentukan. Yang tentunya bisa digunakan juga untuk install LiteSpeed versi terbaru saat ini yaitu LiteSpeed Versi 5.2.1

Maka kita gunakan perintah :

/usr/local/lsws/admin/misc/lsup.sh -f -v 5.2.1

Demikian tulisan singkat ini, semoga bermanfaat.

Blokir semua situs di MikroTik kecuali situs tertentu

Published on September 25, 2017, by in Tutorial.

Mungkin judulnya kepanjangan ya, tapi emang ini catatan untuk Blokir semua situs di MikroTik kecuali situs tertentu.

Cara yang biasa digunakan yaitu menggunakan Layer 7 Protocol atau proxy, tapi kali ini kita hanya menggunakan fungsi Filter pada mikrotik. Cara ini digunakan karena cukup ringan digunakan pada mikrotik versi berapapun.

Konsepnya disini adalah hanya wesite google yang dijikan dan menutup semua akses pada komputer dengan ip 192.168.1.2

Kita buka mikrotik, langsung ke menu :

IP -> Firewall -> Filter Rules

Kemudian ikuti petunjuk firewall berikut :

/ip firewall filter add chain=forward dst-port=80 src-address=192.168.1.2 dst-address=74.125.200.103 protocol=tcp action=accept

/ip firewall filter add chain=forward dst-port=443 src-address=192.168.1.2 dst-address=74.125.200.103 protocol=tcp action=accept

/ip firewall filter add chain=forward dst-port=80 src-address=192.168.1.2 protocol=tcp action=drop

/ip firewall filter add chain=forward dst-port=443 src-address=192.168.1.2 protocol=tcp action=drop

Keterangan :

  • 192.168.1.2 adalah ip lokal komputer target
  • 74.125.200.103 adalah ip address publik situs tertentu yang akan dibuka

Kemudian test pada komputer yang memiliki ip lokal 192.168.1.2 tersebut. Selamat anda berhasil .. hehe.

Install cPanel DNSONLY

Published on September 20, 2017, by in Tutorial.

Untuk menginstal cPanel DNSONLY, lakukan langkah-langkah berikut:

Untuk membuka direktori / home, jalankan perintah berikut:

cd /home

Untuk mengambil file instalasi terbaru dari server cPanel, jalankan perintah berikut:

curl -o latest-dnsonly -L https://securedownloads.cpanel.net/latest-dnsonly

Untuk membuka dan menjalankan file penginstalan, jalankan perintah berikut:

sh latest-dnsonly

Demikian, semoga bermanfaat.

Referensi : https://documentation.cpanel.net/display/ALD/Installation+Guide+-+cPanel+DNSONLY+Installation